あっぷあっぷ

WordPress(このサイト)のバージョンは
管理メニューにて、ちょこちょこ適当にあげてやっていたのだ。

が・・・!
いつも、エラーが残って(ノ_δ。)

そこで久しぶりに、ちょっと時間と気持ちに余裕があり
根本的に解決しようと思い立ち最新バージョンを見ることにした

2.8xから2.9xまで上がってる・・・。
これは何かが変わったんだろうな
どうも使用してるMySQLのバージョンの最低ベースが上がったのか?
よく読んでないが、そんなところだ(笑)

借りてるサーバーはMySQLのバージョンが4.x台と5.x台
2つ使えマスヨーて書いてたような・・・。
そういう時代なんだな・・・
しばらく離れてるうちに
といっても、そんなに離れてるつもりはなかったのに(笑)
しかもプラグインもPHP5が主流になっているし

いや~~もぅ><。
DBもインポート失敗するしぃ~~~
ダメダメな人になった自分にすこし気落ちを感じて
昨夜は寝た。

今朝、思い直してDBのインポートエラーをよぉぉく見る
よく分からないけど、文字コードのような気がする(笑)
なぜか、この手のカンは当たるのだ!昔から
もっと他のことに鋭くなりたい気もするケドね・・・。

MySQL4管理ツールとMySQL5管理ツール並べて手順を見たが
間違ってナインダケド・・・
・・・そういえばこの手のblogてUTF-8だった
きっとコレだ・・・つい昔のクセでeucとかにしてしまう(笑)
これで無事にDBは移行カンリョ

WPのほうは、昨夜ちと動揺して旧バージョンに戻したので
再度アップグレードかけてみると
パズルがハマるように収拾したv

ちと、なんかFTPがサボったらしく
2009年8月の写真が居なくなったりもしたが
原本があるので泣かない><b
また、気が向いたら戻したりするかもですワ❤

スーグラフトン風に
「UはUPGRADのU」とでも〆たいとこだけど、
実際はあっぷあっぷのUでした(笑)

2件のコメント

  1. 文字コードはハマリますよねー
    UTF-8が多くなってる中でSJISとの変換トラブルとか…
    お客様が諦めてくれたら早いんだけど(笑)

  2. >お客様が諦めてくれたら早いんだけど(笑)

    あ、あきらめないと思う・・・(・_・;
    最初はナンダロウって思うよねぇ
    コードとか根幹に関るもん増やすなーーって言いたい(笑)

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です